Message: "You have a newer version of the product already installed..." when installing Norton Security Online for Mac

"You have a newer version of the product already installed. We currently do not support downgrade of our product. Please Contact Support."

This message typically appears during installation when you already have the latest version of Norton Security.

As an Xfinity customer, you may ignore this message. You are seeing this message because your current Mac protection is the same protection you would receive from Norton Security Online.

If you are seeing this message, you have the most current Mac protection offered from Xfinity, and have no further action to take regarding the installation of your product.

Thank you!

Thank you for using Norton Support.

< Back

The solution made it easy for me to handle my issue.

Yes No

Help us improve this solution.

Thank you for helping to improve this experience.

What would you like to do now?

Browse for solutions, search the Norton Community, or Contact Us.

DOCID: v132584556_EndUserProfile_en_us
Operating System: Mac OS X
Last modified: 04/25/2019