Other products

System requirements for Norton Snap

To install Norton Snap on your device, your device must meet the following minimum requirements:

System requirements

    • Device Requirement:

      • Apple iPhone, iPod touch, and iPad

      • Android phones and tablets

      • 1 MB of storage

      • Camera with optional flash

      • Internet connection

    • Operating Systems:

      • iOS 4.3 or later

      • Android OS 4.0.3 or later

    Norton Snap is not compatible with iOS 11.0 or later.

Thank you!

Thank you for using Norton Support.

< Back

The solution made it easy for me to handle my issue.

Yes No

Help us improve this solution.

Thank you for helping to improve this experience.

What would you like to do now?

Browse for solutions, search the Norton Community, or Contact Us.

DOCID: v64690974_EndUserProfile_en_us
Operating System: Android, iOS
Last modified: 10/12/2017