Message: "You need Mac OS X 10.7.5 or later to install this Norton product..."

To successfully install your Norton product for Mac version 7.x, you need to have Mac OS X 10.7.5 or later.

If you have an older version of Mac OS X, we recommend that you upgrade your Mac OS to the latest version. For more information, read How to get macOS Sierra.

Thank you!

Thank you for using Norton Support.

< Back

The solution made it easy for me to handle my issue.

Yes No

Help us improve this solution.

Thank you for helping to improve this experience.

What would you like to do now?

Browse for solutions, search the Norton Community, or Contact Us.

DOCID: v119986269_EndUserProfile_en_us
Operating System: Mac OS X
Last modified: 07/03/2017