Other products

Install your Norton product

Your Norton product is supported only on Mac OS X 10.7.5 (Lion) or later. If your Mac runs on OS X 10.6 or earlier, upgrade your Mac operating system to the supported version.

To install Norton product version 8.x or later, you need to have Mac OS X 10.10.x or later.

Before you install your Norton product, Symantec recommends that you click Norton License Agreement and read your product license agreement.

Thank you!

Thank you for using Norton Support.

< Back

The solution made it easy for me to handle my issue.

Yes No

Help us improve this solution.

Thank you for helping to improve this experience.

What would you like to do now?

Browse for solutions, search the Norton Community, or Contact Us.

DOCID: v100803770_nsmac_retail_en_us
Operating System: Mac OS X
Last modified: 09/21/2018