System requirements for Norton Dark Web Monitoring powered by LifeLock

Applicable only for Canada, Japan, and US.

To successfully install and use Norton Dark Web Monitoring powered by LifeLock, your device must meet the following minimum requirements:

Browser support on Windows PC and Mac

  • Safari 11 or later

  • Firefox 66 or later

  • Google Chrome 73 or later

  • Internet Explorer 11 or later

  • Edge 41.1 or later

Browser support on mobile devices

  • Android Chrome 71 or later

  • iPhone Safari 11.1 or later

  • iPad Safari 11 or later

App support

  • Android 4.4 or later

  • iOS 10.3 or later

The solution made it easy for me to handle my issue.

Yes No

Help us improve this solution.

Thank you for helping to improve this experience.

What would you like to do now?

Browse for solutions, search the Norton Community, or Contact Us.

DOCID: v133310913
Operating System: 
Last modified: 11/28/2019